Back to overview
Resolved
Studio was probably unavailable to you
Jun 1, 2026 at 2:56am UTC
Affected services
Studio App
Resolved
Jun 1, 2026 at 2:56am UTC
We updated DNS for studio.chowmein.tv after a domain change. Some DNS resolvers (especially home ISP/router DNS) still returned “domain doesn’t exist” until their cache updated. Affected users could fix it by switching to public DNS (1.1.1.1 / 8.8.8.8) or waiting for propagation.
Affected services